[RESOLVED!] My brand new A119 V3 can't format SD Card?

sam_sfchiu

New Member
Joined
Jun 25, 2020
Messages
5
Points
3
I got this device yesterday and was excited to start to use it. My another DVR works very well with a kingston 64GB SD Card. So, I use that SD Card to put into this A119. And it started to record. I did test some recording resolutions and formats of this A119 with that kingston 64GB SD Card. Everything looked good then but not later.

Then, I decided to format this SD Card and I use Format function in A119 Menu. No matter how many times I've tried. After clicking Yes/OK to perform formatting SD Card, nothing happened?!?! My old files/folders were still there.

I've used h2testw to check this card and the result is good. I've used GUIFormat to format this card with FAT32 and it's good. But after that, once I put this SD Card into A119, it always says 'Memory Error'. OK! Then I go to Format function in Menu, and again, nothing happened to my SD Card no matter how many times I clicked Yes/OK to perform formatting.

What should I do now? Since my first test of recording worked fine, I am worrying about changing another SD Card won't change the issue.
 

Capture Your Action

Active Member
Joined
Feb 24, 2019
Messages
917
Points
43
Try using SDFormatter. Do the full overwrite, not the quick format.


After using SDFormatter, format inside the camera again.

If that does not help, I would go into the cameras settings and manually default the cameras settings. Change nothing but the time and date, then try.
 

sam_sfchiu

New Member
Joined
Jun 25, 2020
Messages
5
Points
3
Try using SDFormatter. Do the full overwrite, not the quick format.


After using SDFormatter, format inside the camera again.

If that does not help, I would go into the cameras settings and manually default the cameras settings. Change nothing but the time and date, then try.
OK! I forgot to tell you that, I did use SD Card Formatter to fully format my SD Card. And of course, the problem is, no matter how, The Format function in Camera doesn't work. It does nothing changed to SD Card. Just want to say that, that Format function just like a fake function in my A119. Furthermore, this is brand new device and I didn't change any setting/configuration. Of course I also did restore to factory default even that is meaningless.

My problem is this device can't format the SD Card. I also tried another card and had the same issue.
 

sam_sfchiu

New Member
Joined
Jun 25, 2020
Messages
5
Points
3
What was the other card you tried? Brand and model?
SP 16GB

I think I found how to resolve not recording issue after trying and trying, and trying. But the Format function in A119 still has no effect to SD Cards. It's weird.

Use GUIFormat to format the SD Card, and don't change the Allocation Unit Size of formatting options. If you really need to change that, I've tested both 16384 and 32768 are fine. I used to use small cluster size in the past. So when I was performing formatting in GUIFormat, I selected 512 or 1024 and that caused the problem of no recording in A119 (Memory Error). I formatted these SD Card times to test different Allocation Unit Size and got the recording function back.

But my question is still there. If I need to use A119 to format these cards, A119 Format function does nothing to my two SD Cards. I plan to forget this since my A119 is OK to record now but this is really sucks since my A119 is brand new. It spent my whole day.
 
Last edited:

Capture Your Action

Active Member
Joined
Feb 24, 2019
Messages
917
Points
43
Shouldn’t need to change any parameters when formatting. Changing things from default is just asking for issues. Format with SDFormatter, which is the industry standard format. As to why the A119V3 won’t format your card, I can’t say. I know many have had issues with Kingston cards. However, I’ve had good luck with Silicon Power cards (I assume the SP You wrote stood for Silicon Power?). Maybe your model has a different controller and the camera doesn’t like it.
 

sam_sfchiu

New Member
Joined
Jun 25, 2020
Messages
5
Points
3
Shouldn’t need to change any parameters when formatting. Changing things from default is just asking for issues. Format with SDFormatter, which is the industry standard format. As to why the A119V3 won’t format your card, I can’t say. I know many have had issues with Kingston cards. However, I’ve had good luck with Silicon Power cards (I assume the SP You wrote stood for Silicon Power?). Maybe your model has a different controller and the camera doesn’t like it.
Yes. I was talking about silicon-power SD Card. :)
 

sam_sfchiu

New Member
Joined
Jun 25, 2020
Messages
5
Points
3
RESOLVED! After adopting the 2.0T FW and I can now use my camera to format my SD card now. I don't want to guess but seems this is a known issue but will be fixed in the newly released FW sooner later.
 
Top