A129 Duo Firmware V.2.2

skerekeke

New Member
Joined
May 26, 2021
Messages
2
Points
1
Hello Everyone!
I bought a 129 duo from Amazon. Checking the firmware camera is V.2.2. How is it possible? On the site, the latest downloadable firmware is v.2.1 with no mention of v2.2...
Another question.. Buffered parking mode work with this Firmware on this mode? I tried to search, I did not find information about this firmware (2.2), and in general I found conflicting information about the functioning of the buffering parking mode.

thanks for the clarification
 

Capture Your Action

Well-Known Member
Joined
Feb 24, 2019
Messages
1,406
Points
63
Yes, the A129 DUO has buffered parking mode (Auto Event Detection). It was removed only on the Plus model.

Just leave V2.2 on the camera. Likely a minor change, which isn't worth posting on the main Viofo firmware site yet.
 

viofo

Administrator
Staff member
Joined
May 30, 2018
Messages
412
Points
28
Hello,

V2.2 is the latest firmware of A129 Duo. And Buffered parking mode can work well with this firmware.

Sorry for the un-updating site information. Please feel free to contact me if you have any questions about our product!
 

technokami

New Member
Joined
Jun 11, 2021
Messages
2
Points
1
Hello,

V2.2 is the latest firmware of A129 Duo. And Buffered parking mode can work well with this firmware.

Sorry for the un-updating site information. Please feel free to contact me if you have any questions about our product!
Where can we obtain v2.2 from? Is there a changelog available for the new version?
 
Last edited:

viofo

Administrator
Staff member
Joined
May 30, 2018
Messages
412
Points
28
Where can we obtain


Where can we obtain v2.2 from? Is there a changelog available for the new version?
Attached is the V2.2 firmware of A129 Duo. You can use a card reader to connect the computer to format your SD card as FAT32 first, and then download the firmware bin file into the root of your SD card.

After that, insert the SD card into the dashcam, the cam will automatically upgrade.

The REC LED will be blinking while upgrading, and the dashcam will restart after finishing upgrading.
 

Attachments

reCAPTCHAsux

New Member
Joined
Jul 22, 2021
Messages
2
Points
1
Dear Viofo,

If the latest version for this camera is 2.2, could you please update this information on the product page?
Over here it says the latest version is still 2.1.

I had to create an account and login to download 2.2 from this post.

EDIT: Okay, just copied this file to the SD card, inserted it and powered the camera on over USB charger.
The file disappeared on the SD card, and the camera now says it's version A129: V2.0 Build: 20200715.
 
Last edited:

VIOFO-Support

Administrator
Joined
Jul 16, 2021
Messages
321
Points
28
Dear Viofo,

If the latest version for this camera is 2.2, could you please update this information on the product page?
Over here it says the latest version is still 2.1.

I had to create an account and login to download 2.2 from this post.

EDIT: Okay, just copied this file to the SD card, inserted it and powered the camera on over USB charger.
The file disappeared on the SD card, and the camera now says it's version A129: V2.0 Build: 20200715.
Hello,

Please try again referring to this detailed firmware updating instruction: VIOFO Firmware Update Guide Step-by-Step - VIOFO Official Website
 

reCAPTCHAsux

New Member
Joined
Jul 22, 2021
Messages
2
Points
1
Dear Viofo,

Thank you for your reply. I don't know what's going on here. I've tried to follow that guide, but the firmware doesn't seem to update properly. I downloaded the V2.1 firmware file FWA129.bin (SHA1: 6941acde9996441d219850f53b8cf8460c9567bd) from the page that was linked in the guide that you posted:


The SD card I am using (Kingston Endurance 128GB) was already formatted FAT32 and I've used it to record videos with this dashcam in the past. So all I did was use a laptop card reader to delete all the videos and folders on the card and clean up the trash folder to get an empty card. I then put the file FWA129.bin on the root of the SD card and safely removed it from the card reader. Next I inserted the card into the A129 camera while it was disconnected. Then I connected the camera to a 5VDC 2A adapter power supply over a USB cable and the camera powered on. First I saw the left REC red light turn on (IT WAS NOT FLASHING!!!), then after about 12 seconds the right MIC light turned on and the camera played its welcome sound and started recording. I stopped the recording by pressing the REC button and then pressed the leftmost button to open the menu to check the firmware version. It was still labeled A129: v2.0 Build: 20200715.

I removed the cable to power the camera off and took out the SD card and put it back into the laptop. The file FWA129.bin that I've put on the card earlier had disappeared. I tried the same procedure with FWA129.bin version 2.2 (SHA1: eeaee5cd6ab7dec9564a6a1d2fe3142a772dae97) that was posted in this topic and the same thing happens. The camera settings do get reset though.
 

VIOFO-Support

Administrator
Joined
Jul 16, 2021
Messages
321
Points
28
Hi,

After you update the firmware, please go into the settings and manually default the camera's settings. After defaulting to the settings, press and hold the hard reset button on the side of the camera for about 5 seconds.
 

hoffeck

New Member
Joined
Aug 23, 2021
Messages
3
Points
1
@VIOFO-Support
I have version 2.2 installed on me. Works quite well so far.
The buffered parking mode does not work properly. The clips are one minute long and start exactly at the trigger point and not 15 seconds earlier.
My dashcam is connected with the Viofo hard wire kit.
Switching to parking mode and back works.

If you need tester for the firmware, PM me.

Greeting Mario
 

VIOFO-Support

Administrator
Joined
Jul 16, 2021
Messages
321
Points
28
Hi Mario!

Thank you! I'll keep you informed if we need testers for the new firmware of A129 Duo.

The buffered parking mode does not work properly. The clips are one minute long and start exactly at the trigger point and not 15 seconds earlier.
May I know what card do you use? Did you ever format the card recently?
 

hoffeck

New Member
Joined
Aug 23, 2021
Messages
3
Points
1
@VIOFO-Support

Thanks for the quick reply.

My card is a SanDisk High Endurance 128Gb.
I format these at regular intervals in the dashcam. Finally, I formatted the card directly after installing the 2.2 firmware.
After installation, I also reset the dashcam to factory settings.

Greeting Mario
 

hoffeck

New Member
Joined
Aug 23, 2021
Messages
3
Points
1
Yes. At the moment I am back to the 1.9
That's where the buffered parking mode works.
All files are 45 sec long. 15sec before and 30sec after trigger.

So the card is not the problem. This is sufficiently fast and specially designed for use in dashcam and surveillance cameras.

The problem is defenitive your firmware.

By the way, the parking mode motion detection is to sensitive. I set it to "low" and the dashcam picks up every little movement even in the distance.
 
Top